Skip to content

Unsupported engine warning, even when node + npm versions meet requirement #163

Open

Description

@chuank

Installing this via npm returns the following Unsupported engine warning:

image

It also appears that the package needs to have some of its dependencies updated (as per screenshot, for formidable, superagent and core-js.

Activity

  1. chuank commented on Aug 25, 2023

    @chuank
    Author

    Digging a bit deeper, it appears that the superagent dependency can be trivially upgraded to ^7.0.2.
    This will also resolve the formidable dependency in superagent.

    The more challenging dependency is babel-runtime@6.9.2, which still relies on core-js@2.6.12. There are quite a few Babel 6 devDependencies being used which I presume will take a while to upgrade to Babel 7?

    Edit: also, if the npm engine version is updated to support 9.x, that will be great.

  2. equilet commented on Oct 2, 2024

    @equilet

    I also get this

    npm WARN EBADENGINE Unsupported engine {
    npm WARN EBADENGINE   package: 'particle-api-js@11.0.0',
    npm WARN EBADENGINE   required: { node: '>=12.x', npm: '8.x' },
    npm WARN EBADENGINE   current: { node: 'v18.17.1', npm: '10.1.0' }
    npm WARN EBADENGINE }
    
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions